ATMS SDR 2.0.1 insufficient USNO-PolarWander-UT1-ANC-Int anc

Advanced Technology Microwave Sounder Sensor Data Record

ATMS SDR 2.0.1 insufficient USNO-PolarWander-UT1-ANC-Int anc

Postby smasse » Fri Dec 05, 2014 6:37 pm

I am running atms_sdr.sh (SDR 2.0.1) on pass 20141204195832 and fails to generate datasets.
Can anyone tell me what is the meaning of the "insufficient USNO-PolarWander..." messages
in the log shown below?

Serge Masse, Global Imaging.

(INFO):adl_asc.py:contiguous_granule_groups:330:contiguous sequence has 20 granules
(INFO):adl_atms_sdr.py:populate_ancillary_links:589:downloading TLE and PolarWander ancillary into cache and linking into workspace
(INFO):adl_atms_sdr.py:populate_ancillary_links:596:Link the required ancillary data into the workspace
(WARNING):adl_asc.py:effective_anc_contains:372:insufficient USNO-PolarWander-UT1-ANC-Int ancillary coverage for NPP000983951585
<16 such messages>
(WARNING):adl_asc.py:effective_anc_contains:372:insufficient USNO-PolarWander-UT1-ANC-Int ancillary coverage for NPP000983957025
(ERROR):adl_atms_sdr.py:check_ancillary_effectivity:617:Insufficient polar wander coverage for 18 of the candidate granules. Recommend fetching new PolarWander files.
(INFO):adl_atms_sdr.py:atms_sdr:659:running SDR on XML files
(INFO):adl_atms_sdr.py:run_all_granules:451:0 granules to process
(INFO):adl_atms_sdr.py:run_all_granules:459:Process gran 1 to 0 in sequence of 0
(INFO):adl_atms_sdr.py:cleanup:565:cleaning up work directory...
(INFO):adl_common.py:get_return_code:592:Normal Completion.
smasse
 
Posts: 5
Joined: Fri Dec 05, 2014 6:08 pm

Re: ATMS SDR 2.0.1 insufficient USNO-PolarWander-UT1-ANC-Int

Postby kathys » Mon Dec 08, 2014 12:57 pm

Dear Sir,

The message means that the Polar Wander files you are using are too far out of date. Are you running the atms_sdr.sh script and using the default method of downloading the required ancillary files as they are processed, or are you acquiring the files in some other way?

Kathy
kathys
 
Posts: 183
Joined: Tue Jun 22, 2010 4:51 pm

Re: ATMS SDR 2.0.1 insufficient USNO-PolarWander-UT1-ANC-Int

Postby smasse » Mon Dec 08, 2014 1:39 pm

I am running atm_sdr.sh and using the defaults for SDR 2.0.1.
smasse
 
Posts: 5
Joined: Fri Dec 05, 2014 6:08 pm

Re: ATMS SDR 2.0.1 insufficient USNO-PolarWander-UT1-ANC-Int

Postby kathys » Mon Dec 08, 2014 6:17 pm

Very strange. I am sorry you are having problems. Have you ever had problems like this before?

Can you please provide us with the RDR file you are trying to process? Feel free to push it to our anonymous ftp site if you would like at: ftp://ftp.ssec.wisc.edu/pub/incoming/

Kathy
kathys
 
Posts: 183
Joined: Tue Jun 22, 2010 4:51 pm

Re: ATMS SDR 2.0.1 insufficient USNO-PolarWander-UT1-ANC-Int

Postby smasse » Mon Dec 08, 2014 7:32 pm

Thanks you for checking this out.
I will upload the RDR tomorrow.

Regards,

Serge
smasse
 
Posts: 5
Joined: Fri Dec 05, 2014 6:08 pm

Re: ATMS SDR 2.0.1 insufficient USNO-PolarWander-UT1-ANC-Int

Postby smasse » Tue Dec 09, 2014 3:42 pm

I have uploaded these RDR files to the FTP site:
RATMS-RNSCA_npp_d20141204_t1958260_e2009414_b00001_c20141205033635753000_all-_dev.h5
RCRIS-RNSCA_npp_d20141204_t1958314_e2009418_b00001_c20141205033635715000_all-_dev.h5
RNSCA-RVIRS_npp_d20141204_t1958316_e2009406_b00001_c20141205033635525000_all-_dev.h5
smasse
 
Posts: 5
Joined: Fri Dec 05, 2014 6:08 pm

Re: ATMS SDR 2.0.1 insufficient USNO-PolarWander-UT1-ANC-Int

Postby kathys » Tue Dec 09, 2014 6:30 pm

We have identified your problem as a bug in the script that chooses the correct Polar Wander ancillary file. It was introduced with the release of the new v2.0 CSPP SDR software package. This bug does not affect real-time processing, but will affect some days when processing historical data sets. To fix this problem, first delete your local version of the ${CSPP_SDR_HOME}/common/get_anc_jpss_polarwander.bash script, and replace it with an updated version: ftp://ftp.ssec.wisc.edu/pub/CSPP/pw_scr ... ander.bash . Make sure the file is executable: chmod guo+x ${CSPP_SDR_HOME}/common/get_anc_jpss_polarwander.bash and try processing your data set again.

We also strongly recommend that you update your version of RT-STPS to the V 5.6, the current version, which handles the new S-NPP direct broadcast in a better way.

Please let me know if this resolves your problem, and we apologize for this inconvenience.

Kathy
kathys
 
Posts: 183
Joined: Tue Jun 22, 2010 4:51 pm


Return to ATMS SDR

Who is online

Users browsing this forum: No registered users and 1 guest

cron