Problem in SDR files

VIIRS Sensor Data Record
Post Reply
a_luthfi
Posts: 4
Joined: Mon May 18, 2015 6:51 pm

Problem in SDR files

Post by a_luthfi »

Dear all,

I think I have problem with SDR processing. It seems the data was cut into several sequences, I attached the look of the files and folders created. The SDR data is stored in every folders as shown in the pict (NPP0011...).
A log file is also created (I attached it) which shows there are some errors. I have updated the CSPP SDR software to version 2.1 and updated the LUTs, the result is still the same.

If you read the log file, we made several scripts to help in automatisation of the process. Please let me know your advice.

Thanks,
Luthfi
Attachments
SDR files and folders
SDR files and folders
sdr product.jpg (358.55 KiB) Viewed 4379 times

[The extension log has been deactivated and can no longer be displayed.]

kathys
Posts: 374
Joined: Tue Jun 22, 2010 4:51 pm

Re: Problem in SDR files

Post by kathys »

We are investigating the problems that you are seeing. Can you provide us with some information about the system you are running on? What platform/OS memory and data storage do you have?

Thank you,

Kathy
a_luthfi
Posts: 4
Joined: Mon May 18, 2015 6:51 pm

Re: Problem in SDR files

Post by a_luthfi »

Hi Kathy,

I am using Linux CentOS 6.5 on 8 core Xeon server @2.00GHz with 31.4 GB memory and 2 TB data storage.

The software was installed in the middle of last year. It worked well at that time. Then in December this problem happened.
I try to activate again this system and have a thought that it may need an update, but still not work. I only updated the SDR processing.

Thank you,
Luthfi
a_luthfi
Posts: 4
Joined: Mon May 18, 2015 6:51 pm

Re: Problem in SDR files

Post by a_luthfi »

I've just noticed that there are no data in the folders NPP0011..., but an xml file was created. I attached the file.

Regards,
Luthfi
Attachments

[The extension xml has been deactivated and can no longer be displayed.]

a_luthfi
Posts: 4
Joined: Mon May 18, 2015 6:51 pm

Re: Problem in SDR files

Post by a_luthfi »

Hi Kathy,

I think I found the problem. There is a env. variable which is set with value, namely DCONFIG. When I do unsetting this variable, processing works.
I still don't know in which file / config this variable was set.

Regards,
Luthfi
kathys
Posts: 374
Joined: Tue Jun 22, 2010 4:51 pm

Re: Problem in SDR files

Post by kathys »

We are trying to diagnose your problem. We are wondering how you decided to check on the DCONFIG environment variable? If this is not set correctly, you are right, the SDR software will not execute correctly. We are not sure how it would come to be set incorrectly, since it is actually set through the cspp_sdr_runtime.sh script, which is sourced when the viirs_sdr.sh is executed. We suspect that if you were running an older version of the software on the same system, it might be left over from that installation?
Post Reply