Granules not mapping correctly

VIIRS Sensor Data Record

Granules not mapping correctly

Postby pmluser » Tue Mar 01, 2016 5:33 am

Dear SSEC,

I am trying to process some VIIRS L0 data to L1B (an eventually to L2). However, the outputs for each granule do not appear to be a consistent size across each band/product. This leads to bizarre 'boxes' of missing data when the granules are arggregated into a swath (see L2_combined product). Attached are examples of the SVDNB, SVI01 and SVM01 radiance bands for a single granule. Only the former appears to map correctly (when opened in Beam). The raster images are 4064 x 768, 6400 x 1536 and 3200 x 768 respectively. I have attempted to process each granule individually (without the aggregate switch), with the same effect. This problem is occurs in every swath I have attempted to process so far. Are you able to suggest why this is happening?

I am new to using CSPP, so I apologise if the question is due to a trivial error.

Thanks for your help,

Ben
Attachments
L2_combined.png
Atmospheric correction failure flag post L1B>L2 processing. Note the odd shape of the 'boxes' of bad data.
L2_combined.png (460.74 KiB) Viewed 3095 times
SVM01.png
SVM01.png (698.12 KiB) Viewed 3095 times
SVDNB.png
SVDNB.png (638.29 KiB) Viewed 3095 times
pmluser
 
Posts: 3
Joined: Tue Mar 01, 2016 4:25 am

Re: Granules not mapping correctly

Postby pmluser » Tue Mar 01, 2016 7:36 am

I should add that I am using CSPP SDR_2.1 patched to 2.1.1, running on 64 bit linux. Ancillary data is provided by a local mirror of the JPSS and OBPG repositories, it is not collected on the fly.
pmluser
 
Posts: 3
Joined: Tue Mar 01, 2016 4:25 am

Re: Granules not mapping correctly

Postby kathys » Tue Mar 01, 2016 12:29 pm

Hi Ben,

Have you used VIIRS data before? Just want to make sure you are aware that VIIRS data has the similar overlap region between scans as MODIS does (they call it the bow-tie), but they handle it in a different way. The overlap regions are not included in the VIIRS data sets (they call that the bow tie deletion). The VIIRS instrument also has different aggregation zones across the swath as it attempts to maintain a more constant FOV size from nadir to high instrument view angles.

If you want to find out more, there is a VIIRS SDR Users' guide online: http://www.star.nesdis.noaa.gov/smcd/sp ... _guide.pdf

This document also has a nice description of this effect - pages 12-14: http://rammb.cira.colostate.edu/project ... y_Data.pdf

I don't know if these things are what is causing the problems you are seeing in your output product images, but if you have worked with VIIRS data before, or this info is not helpful to you, then let us know, and we will investigate further.

Good luck,

Kathy
kathys
 
Posts: 345
Joined: Tue Jun 22, 2010 4:51 pm

Re: Granules not mapping correctly

Postby pmluser » Wed Mar 02, 2016 3:56 am

Thanks for the reply Kathy - as it turns out, my problem is in the generation of the L2 data and not with the L0 > L1B stage at all, so this is very much not a CSPP problem. Thanks anyway for your quick help!

Cheers,

Ben
pmluser
 
Posts: 3
Joined: Tue Mar 01, 2016 4:25 am


Return to VIIRS SDR

Who is online

Users browsing this forum: No registered users and 1 guest