Instructions for ADL4.2 native installation

Issues related to installation of ADL

Instructions for ADL4.2 native installation

Postby jhuangadl » Thu Jan 09, 2014 2:00 pm

Dear all,
Where I can find detailed installation instructions for ADL4.2 native installation on our local linux machine?
The wiki page is still all with 4.1 information and it becomes hard to follow if we want to install ADL4.2 entirely without any dependence on ADL4.1 previous installation.
Any chance?

Also, it seems there are no virtual appliance version of ADL4.2 yet, is it true?

Thanks!
jingfeng
jhuangadl
 
Posts: 142
Joined: Fri Apr 29, 2011 7:57 am

Re: Instructions for ADL4.2 native installation

Postby kbisanz » Thu Jan 09, 2014 6:50 pm

I cannot comment on the virtual appliance. That is the University of Wisconsin who provides that. I took a quick look and I did not see one.

Installing ADL 4.2 shouldn't be much different than ADL 4.1. On DVD1 there should be a README file. Also in user manual part 1 should a section installation.

I've give sort of general answers. Please post back if you have issues.
Kevin Bisanz
Raytheon Company
kbisanz
 
Posts: 280
Joined: Wed Jan 05, 2011 7:02 pm
Location: Omaha NE

Re: Instructions for ADL4.2 native installation

Postby jhuangadl » Fri Jan 10, 2014 3:12 pm

Thank you, Kevin,
I am following the steps in the User Manual to build ADL4.2, here are the errors I have:
Code: Select all
Building src in ./SCIENCE...
make[2]: Entering directory `/data/data003/ADL4.2/ADL/xml/SCIENCE'
/data/data003/ADL4.2/ADL/perl/src/generateSourceFiles.pl /data/data003/ADL4.2/ADL/xml/SCIENCE ADL -h /data/data003/ADL4.2/ADL/include -o /data/data003/ADL4.2/ADL/CMN/Utilities/Dictionary/Entries/SCIENCE/src -e AutoDerivedScienceDictionaryEntries -g AutoGeneratedScienceProductsGbl.h -d /data/data003/ADL4.2/ADL/CMN/ProcessingIO/src -f AutoGeneratedScienceProductsGbl.f
Bareword found where operator expected at /data/data003/ADL4.2/common/COTS/perl/perls/perl-5.15.9/lib/5.15.9/utf8_heavy.pl line 21, near "s/[-\s_]//rg"
syntax error at /data/data003/ADL4.2/common/COTS/perl/perls/perl-5.15.9/lib/5.15.9/utf8_heavy.pl line 21, near "s/[-\s_]//rg"
BEGIN not safe after errors--compilation aborted at /data/data003/ADL4.2/common/COTS/perl/perls/perl-5.15.9/lib/5.15.9/utf8_heavy.pl line 147.
Compilation failed in require at /data/data003/ADL4.2/common/COTS/perl/perls/perl-5.15.9/lib/5.15.9/utf8.pm line 17.
BEGIN failed--compilation aborted at /data/data003/ADL4.2/common/COTS/perl/perls/perl-5.15.9/lib/5.15.9/constant.pm line 45.
Compilation failed in require at /data/data003/ADL4.2/common/COTS/perl/perls/perl-5.15.9/lib/5.15.9/File/stat.pm line 143.
BEGIN failed--compilation aborted at /data/data003/ADL4.2/common/COTS/perl/perls/perl-5.15.9/lib/5.15.9/File/stat.pm line 143.
Compilation failed in require at /data/data003/ADL4.2/ADL/perl/src/generateSourceFiles.pl line 91.
BEGIN failed--compilation aborted at /data/data003/ADL4.2/ADL/perl/src/generateSourceFiles.pl line 91.
make[2]: *** [/data/data003/ADL4.2/ADL/include/AutoDerivedScienceDictionaryEntries.h] Error 255
make[2]: Leaving directory `/data/data003/ADL4.2/ADL/xml/SCIENCE'
make[1]: *** [src] Error 2
make[1]: Leaving directory `/data/data003/ADL4.2/ADL/xml'
make: *** [src] Error 2

It seems I am missing quite some files. Any ideas to shed lights on my path? Thanks!
jhuangadl
 
Posts: 142
Joined: Fri Apr 29, 2011 7:57 am

Re: Instructions for ADL4.2 native installation

Postby houchin » Fri Jan 10, 2014 4:23 pm

I would get rid of the perl installation within /data/data003/ADL4.2/common.

I have installed ADL many times on both Aerospace linux servers running CentOS and Scientific Linux, and on GRAVITE, and in all cases the default system installation of perl was sufficient.

Back in the ADL 3 timeframe, I did try get ADL installed with the version of perl installed by the UW scripts, since that was the default for those support scripts, and I think I had similar errors.

GRAVITE is running RHEL 5.10, with perl 5.8.8
The current Aerospace servers are running Scientific Linux 6.4, with perl 5.10.1
The older Aerospace servers are running CentOS 5.10 with perl 5.8.8
Scott Houchin, Senior Engineering Specialist, The Aerospace Corporation
15049 Conference Center Dr CH3/310, Chantilly, VA 20151; 571-307-3914; scott.houchin@aero.org
houchin
 
Posts: 128
Joined: Mon Jan 10, 2011 6:20 am

Re: Instructions for ADL4.2 native installation

Postby jhuangadl » Fri Jan 10, 2014 4:42 pm

Thanks, Scott,
I am installing another version of perl from ssec to check whether it is the perl version problem. Will update afterwards.
We were compiling ADL4.1 fine with the existing perl though.
Jingfeng
jhuangadl
 
Posts: 142
Joined: Fri Apr 29, 2011 7:57 am

Re: Instructions for ADL4.2 native installation

Postby jhuangadl » Thu Jan 16, 2014 4:07 pm

The problem indeed was from the COTS installation. I have successfully built the ADL4.2 by using another more updated version of COTS installation. Thanks!
jhuangadl
 
Posts: 142
Joined: Fri Apr 29, 2011 7:57 am


Re: Instructions for ADL4.2 native installation

Postby scottm » Thu Dec 11, 2014 3:28 pm

Just a note, the new download site is here http://download.ssec.wisc.edu/sys/login/form/adl -
https://jpss.ssec.wisc.edu/jpss-data/ht ... lation.pdf

On Perl,
On most systems people will find that the default perl installation works fine. Red Hat 5, Centos 5 versions had issues.

A new virtual machine based on mx8.06 will be posted soon.
scottm
 
Posts: 87
Joined: Thu Jan 06, 2011 9:25 am

Re: Instructions for ADL4.2 native installation

Postby belalctg276 » Thu Sep 15, 2016 11:51 am

This is very helpful post.Thank you for your good article.I am give
here a link which help you to found more good article.

http://www.wikipedia.org
belalctg276
 
Posts: 1
Joined: Thu Sep 15, 2016 11:43 am


Return to Installation

Who is online

Users browsing this forum: No registered users and 0 guests

cron