VIIRS ERROR adl_anc_retrieval.py

VIIRS Sensor Data Record
Post Reply
panjir85
Posts: 3
Joined: Mon Jan 17, 2022 2:06 am

VIIRS ERROR adl_anc_retrieval.py

Post by panjir85 »

Hi, I have a problem when processing the RDR data to SDR data.
The following error message appears:

(ERROR):adl_anc_retrieval.py:service_remote_ancillary:177:Critical file missing:RSB

Please help and advise. Thank you.
kathys
Posts: 376
Joined: Tue Jun 22, 2010 4:51 pm

Re: VIIRS ERROR adl_anc_retrieval.py

Post by kathys »

Dear Colleague,

I will try and help you with the problem you are having. Can you please provide me with more information?

You are trying to execute the CSPP SDR software, is that correct?

— What version of the CSPP SDR software are you using?
— What command are you using to execute the software?
— Did you verify your SDR installation? There is a test dataset that is part of the CSPP SDR 3.3 software packages that you can use for verification.
— — If the verification fails, can you please run the software again using the “-d” option and then send us the log file that remains?
— What Operating System are you using?

Good luck,

Kathy
panjir85
Posts: 3
Joined: Mon Jan 17, 2022 2:06 am

Re: VIIRS ERROR adl_anc_retrieval.py

Post by panjir85 »

Dear Kathy,

Thanks for the response to my post, the following is the answers to all your question:

Q: What version of the CSPP SDR software are you using?
A: SDR 3.1

Q: What command are you using to execute the software?
A: viirs_sdr.sh -d -p 2 -a -g /archive/data/RDR/VIIRS/2022/01/14/0642024/RNSCA-RVIRS_j01_d20220114_t0642024_e0649091_b00001_c20220114083000621000_all-_dev.h5

Q: Did you verify your SDR installation? There is a test dataset that is part of the CSPP SDR 3.3 software packages that you can use for verification.
A: My CSPP SDR is 3.1 version, there is a test dataset for verification of my installation?

Q: What Operating System are you using?
A: CentOS Linux 7 (Core)

Regards
kathys
Posts: 376
Joined: Tue Jun 22, 2010 4:51 pm

Re: VIIRS ERROR adl_anc_retrieval.py

Post by kathys »

Thank you for sending us more information.

Since you used the -d option with your CSPP SDR execution, you should have a log file that remains if your execution failed. Can you please send that to us? You can either attach it to an email, or you can upload and attachment through this Forum.

The most recent version of the CSPP software is Version 3.3. We suggest that you upgrade to this version and include execution of the verification test data. It is posted at the CSPP download site along with the rest of the installation tarballs.

Good luck,

Kathy
panjir85
Posts: 3
Joined: Mon Jan 17, 2022 2:06 am

Re: VIIRS ERROR adl_anc_retrieval.py

Post by panjir85 »

Dear Kathy,

I just update my SDR 3.1 to SDR 3.3 and it working properly.
Thanks for your help and advice to me.

Regards
Post Reply